How to solve V2017.3 BMW ICOM ISTA Error in Version Database


Matched product:

Cheap V2017.03 BMW ICOM Software HDD ISTA-D 4.04.12 ISTA-P 3.60.2.001 with Engineers Programming Windows 7 System

Cheap V2017.03 BMW ICOM Software HDD ISTA-D 4.04.12 ISTA-P 3.60.2.001 with Engineers Programming Windows 7 System

$99
  • Item No. SS197-3B
  • Out Of Stock
BMW ICOM Latest software version: V2017.3,Multi-language available in diagnosing, programming and TIS diagram circuit,Supports Engineer programming and Windows 7.
Problem:

I just installed the V2017.3 BMW ICOM ISTA-D 4.04.12 ISTA-P 3.60.2.001 software HDD on Windows 7 laptop. But failed to install and ISTA software gave error:

"Error in version of database

Existing versions of databases are not compatible with each other. Please contact your

Local assistance. The installation may be incomplete."

And then ISTA-P was ready to shut down


I was told it was because the language incompatibility. 


I followed engineer suggestion to change language to English ( or German /Chinese) to check if it is okay. 
This time I can open icom software, but nothing display, all blank.


Final solution:

You need to update your BMW ICOM Next/ICOM A2 firmware to newer to work with newer ISTA software.


How to Update BMW ICOM Firmware?

http://blog.obdii365.com/2017/05/09/free-download-bmw-icom-next-firmware-1-40/

(ICOM Next and ICOM A2 share the same update procedure)